Joomla .htaccess Problem

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • Joomla .htaccess Problem

    Hallo,
    ich betreibe seit kurzem http://www.affiliate-start.de. Im Admin von Joomla! kann man Suchmaschinen freundliche URL anschlaten. Dies habe ich getan und habe wie es gesgat wurde die htaccess.txt Datei in .htaccess umbenannt. Nun, wenn ich http://affiliate-start.de aufrufe, kommt der Fehler 500. Was habe ich falsch gemacht? Ich habe mometan die .htaccess Datei gelöscht, damit wenigstens die Seite wieder online ist.

    Vielen Dank
  • Mod Rewrite ist aktiv

    Loaded Modules mod_userdir, mod_ssl, mod_python, mod_php4, mod_perl, mod_setenvif, mod_so, mod_usertrack, mod_headers, mod_expires, mod_cern_meta, mod_digest, mod_auth_db, mod_auth_dbm, mod_auth_anon, mod_auth, mod_access, mod_rewrite, mod_alias, mod_speling, mod_actions, mod_imap, mod_asis, mod_cgi, mod_dir, mod_autoindex, mod_include, mod_info, mod_status, mod_negotiation, mod_mime, mod_mime_magic, mod_log_referer, mod_log_agent, mod_log_config, mod_define, mod_env, mod_vhost_alias, mod_mmap_static, http_core


    poste doch bitte mal den inhalt der .htaccess datei
  • Inhalt der htaccess von affiliate-start

    affiliate-start wird auf dem gleichem Server wie regon.de gehostet: http://www.regon.de/AFILLIATE-START
    Hier der Inhalt der htaccess.txt:

    Source Code

    1. ##
    2. # @version $Id: htaccess.txt 1005 2005-11-13 17:33:59Z stingrey $
    3. # @package Joomla
    4. # @copyright Copyright (C) 2005 Open Source Matters. All rights reserved.
    5. # @license http://www.gnu.org/copyleft/gpl.html GNU/GPL
    6. # Joomla! is Free Software
    7. ##
    8. Options +FollowSymLinks
    9. #
    10. # mod_rewrite in use
    11. #
    12. RewriteEngine On
    13. # Uncomment following line if your webserver's URL
    14. # is not directly related to physical file paths.
    15. # Update YourJoomlaDirectory (just / for root)
    16. # RewriteBase /YourJoomlaDirectory
    17. #
    18. # Rules
    19. #
    20. RewriteCond %{REQUEST_FILENAME} !\.(jpg|jpeg|gif|png|css|js|pl|txt)$
    21. RewriteCond %{REQUEST_FILENAME} !-f
    22. RewriteCond %{REQUEST_FILENAME} !-d
    23. RewriteRule ^(.*) index.php
    Display All
  • Re: Inhalt der htaccess von affiliate-start

    "regon_de" wrote:

    affiliate-start wird auf dem gleichem Server wie regon.de gehostet: http://www.regon.de/AFILLIATE-START....


    was heißt das?
    wie ist denn deine verzeichnis struktur?

    ~/html/regon.de/..files... => regon.de
    ~/html/affiliate-start.de/..files... => affiliate-start.de

    oder ~/html => regon.de
    ~/html/affiliate-start.de/ => affiliate-start.de

    wo liegt deine .htaccess?

    ist aber nicht dein eigener server, oder?
    ein auszug aus der syslog (/var/log/syslog) würde dann nämlich helfen
  • englisch ist nicht so dein ding, oder?

    # Uncomment following line if your webserver's URL
    # is not directly related to physical file paths.
    # Update YourJoomlaDirectory (just / for root)


    heißt zu deutsch, dass du die raute vor RewriteBase entfernen sollst und den pfad anpassen musst

    Source Code

    1. RewriteBase /AFFILIATE-START


    und diese .htaccess dann ins oberste verzeichnis kopieren
    (bzw. bestehene .htaccess ergänzen)

    sollte so funktionieren
  • http://www.affiliate-start.de/ :cry: Fehler 500

    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, info@itowl.net and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Apache/1.3.28 Server at www.affiliate-start.de Port 80
  • aha.. confixx war der übeltäter..

    hab nen besseren code:

    trag folgenden code für alle kunden ein:

    DEBIAN SERVER
    <Directory "/var/www/##user##/html/">
    AllowOverride All
    Options +FollowSymLinks
    </Directory>


    SUSE SERVER 1)
    <Directory "/srv/www/##user##/html/">
    AllowOverride All
    Options +FollowSymLinks
    </Directory>


    SUSE SERVER 2)
    <Directory "/home/##user##/html/">
    AllowOverride All
    Options +FollowSymLinks
    </Directory>


    Für alle die den Thread sonst noch lesen:
    Ihr findet das im confixx ADMIN -> Einstellungen -> httpd spezial