IIS konfigurieren und PHP integrieren Probleme über Probleme Fehler 401

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • IIS konfigurieren und PHP integrieren Probleme über Probleme Fehler 401

    Hallo,

    Ich probiere nun schon seit Tagen IIS einzurichten und PHP dazu zu installieren.
    Ich kann in dem frisch installierten IIS allerdings nur die automatisch erzeugte Standartseite aufrufen. Keine html und schon garkeine php seite.
    Ich bekomme immer einen 401 Fehler.
    Auch wenn ich php installiere bekomme ich einen 401 Fehler. Es ändert sich zwar der Fehler von 401.5 in 401.3 aber sonst nichts.
    Ich würde gerne eine Komplettanleitung schreiben wenn ich wüsste wie diese Fehler zu beheben sind ich denke es gibt viele andere die darüber dankbar wären. Ich frage mich warum es hierfür noch keine Detailgetreue anleitung gibt.
    wenn ich mit hilfe dieses Forums IIS installieren kann werde ich auf jedenfall ein Tutorial machen.!!!

    Jetzt schon mal dank an Robert der mir schon dabei hilft.


    Würde mich über schnelle Antworten freuen.

    MfG X-HT
  • Deadman44 wrote:

    Nach welcher Anleitung bist du vorgegangen? Oder hast du dich einfach durchgeklickt?
    Interessant für dich wäre vielleicht folgendes:
    iisadmin.co.uk/?p=4
    Besonders unten die Kommentare 110 und 111.


    Also ich habe ihm beim Einrichten vom IIS etwas geholfen. Hab das selbst schon ein/zweimal aus dem Boden gestampft, aber jeweils ohne eine gute Anleitung, sondern verschiedene Anleitungsschnipsel und eigenes Testen. Sobald ich des hier nun durch hab, werd ich mir mal ne eigene Anleitung schreiben *g*

    Aber nun zum Thema:
    Also System is ein Windows2003 Server mit SP2, IIS6.0 und PHP 5.2
    Folgendes wurde bereits abgearbeitet:
    - PHP installiert: ISAPI for IIS
    - Im IIS wurde unter Websites -> Default WebSite -> ein neuer Folder erstellt. Über localhost/foldername/ wird die index.htm aus dem richtigen Verzeichnis C:\...\foldername\index.htm aufgerufen, allerdings kein PHP-Code
    - Des Weiteren wurde unter Webdiensteerweiterung die php.exe hinzugefügt und auf "Zugelassen" gestellt
    - In den Properties von "Default WebSite" wurde unter "Virtuelles Verzeichnis" --> Anwendungskonfiguration die Anwendungserweiterung "php" mit dem Pfad zur zugehörigen DLL hinzugefügt und als Standardinhaltseite die index.htm und die index.php eingetragen
    - Die Datei php.ini wurde angepasst und nach C:\Windows\ kopiert

    So, ich glaub des wars. *g* Ergebnis vom Lied: Unter localhost/foldername/ wird nun die bearbeitete index.htm angezeigt.

    Nun bleiben noch paar Fragen offen:
    - Warum macht er keinen PHP-Support, was fehlt?
    - Das Verzeichnis von localhost/ is ja standardmäßig C:\Inetpub\wwwroot\ hier gibts auch eine index.htm, auf die man aber einen Berechtigungserror kriegt (HTTP Error 401.3 ), obwohl Schreib- und Leserechte in den properties auf das Basisverzeichnis gesetzt wurden.

    Vielen Dank schonmal für die Hilfe. Und wenn des rum is, schreib ich mal ne gscheide Anleitung und stell sie auch rein ;)

    The post was edited 1 time, last by robert712 ().