Eclipse umstellen auf rails 3.1

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • Eclipse umstellen auf rails 3.1

    Ich habe mir auf der Konsole Rails 3.1 und Ruby 1.9.2 installiert. Wenn ich meine Eclipse starte und auf der Eclipse-Konsole rails -v und ruby -v eintippe, werden die alten Versionen angezeigt. Wie kann ich in Eclipse nun auch mit den neuen Versionen arbeiten? Was muss ich ändern?

    Bitte um Eure Hilfe.....
  • Also bei Rails kann man zur Not die gewünschte Versionsnummer angeben, bei dir wäre das dann

    Source Code

    1. rails _3.1.0_ bla

    Ich habe auch erst kürzlich auf Rails 3.1 gewechselt und für existierende Projekte sucht Rails nach der zu verwendenden Version im Gemfile, also evtl. dort mal auf Rails 3.1.0 umstellen und/oder bundle update und bundle install ausführen.
    Wenn du ein neues Projekt mit Rails 3.1 erstellen möchtest, dann kannst du beim ersten mal

    Source Code

    1. rails _3.1.0_ new foo
    ausführen.
    Des weitere glaube ich, dass Rails außerhalb von Projekten immer die zuletzt aufgerufene Version ausführt. Zumindest war bei mir nach kurzer Zeit Rails 3.1 als Standard eingestellt.
    Ansonsten könntest du auch, falls du es nicht mehr benötigst, Rails 3.0 deinstallieren.

    Zu Ruby kann ich leider nichts sagen.
    Open Source --> Programmieren aus Leidenschaft :!:

    Ich stehe weder für privaten Support per PM noch über einen IM zur Verfügung. Danke.